Drupal Wysiwyg CKEDITOR 4.x Algılama Sorunu

Blog Kategori: 

Drupal Wysiwyg eklentisi ckeditor 4 sürümünü algılamada problem yaşamaktadır. Yapacağınız işlem çok basit. Birkaç kod değişikliği ile tanıtabilirsiniz... Kurulum ve düzenleme aşamaları aşağıdaki gibidir...

1. Wysiwyg eklentisini https://drupal.org/project/wysiwyg adresinden indirip FTP ile sitenize bağlanarak /sites/all/modules/wysiwyg klasörü içerisine taşıyın
2. Sitenizin eklentiler menüsünden wysiwyg eklentisini aktifleştirin.
3. http://ckeditor.com/download adresinden ckeditor 4.x sürümlerinden birini indirin.
4. İndirdiğiniz yazı editörünü /sites/all/libraries/ckeditor klasörü içerisine çıkarın.
5. /sites/all/modules/wysiwyg/editors/ckeditor.inc dosyasını not defteri ile açarak aşağıdaki değişikliği yapınız:

    if (preg_match('@version:\'(?:CKEditor )?([\d\.]+)(?:.+revision:\'([\d]+))?@', $line, $version)) {

ifadesini aşağıdaki ifade ile değiştiriniz (buradaki tek fark '(?:CKEditor diye başlarkenki ve +revision:\' diye biterkenki tek tırnağı çift tırnak yapmak

    if (preg_match('@version:\"(?:CKEditor )?([\d\.]+)(?:.+revision:\"([\d]+))?@', $line, $version)) {

değişiklikleri kaydedip admin/config/content/wysiwyg adresine girdiğinizde artık CKEditor 4 sürümünü tanıtmış olacaksınız... Kolay gelsin...

Yeni yorum ekle

GezdeAl.com - Gezmeden Almam Diyenlerin Sitesi