Drupal Güncelleme Engeli: PHP open_basedir restriction Çözümü

-A A +A

Blog Kategori: 

HATA: PHP open_basedir restriction. The testing framework requires the PHP open_basedir restriction to be disabled. Check your webserver configuration or contact your web host.

Bahsedeceğim hata Drupal ile veritabanı güncellemesi yaparken karşılaşabileceğiniz open_basedir restriction hatası. Bu hatayı gidermek için ya PHP.ini dosyasında değişiklik yapacaksınız ya da bazı eklentileri devre dışı bırakacaksınız.
PHP.ini dosyasında değişiklik yapabilmek için host firmanıza danışmanız gerekecektir ve host firmanızda güvenlik açığı oluşacağı gerekçesiyle bu durumun mümkün olmayacağını söyleyecektir. Eğer firma tamam derse veya yönetim sizde ise yapacağı değişiklik http://php.net/manual/en/ini.core.php#ini.open-basedir adresinde belirtilmektedir.
Yok eğer eklenti üzerinden bu sorunu gidereyim derseniz;
Test veya SimpleTest contrib (Provides a framework for unit and functional testing) devre dışı bırakın.
Veya Octopus kullanıcı için drush DBUP komut ile komut satırı, ya da olmayan Octopus kullanıcı standart drush updatedb güncellemeleri çalıştırın.
Daha sonra update.php dosyanızı yeniden çalıştırını. Sorununuz çözüldü ;)

Yeni yorum ekle

Detaylı İçerik Arama

Herhangi bir filtre seçin ve sonuçları görmek için Uygula'ya tıklayın.

Zircon - This is a contributing Drupal Theme
Design by WeebPal.